Ir al contenido
Censys Equipos de búsqueda: Inteligencia de Internet líder del sector para equipos y organizaciones de seguridad en crecimiento | Más información
Blogs

Encontrar servidores de bases de datos Oracle con la vulnerabilidad CVE-2018-3110

Oracle ha revelado recientemente una vulnerabilidad grave (CVE Score: 9.9) en Oracle Database. La vulnerabilidad afecta a 11.2.0.4 y 12.2.0.1 y permite a un atacante que puede iniciar una sesión (es decir, autenticarse con éxito) comprometer completamente el servidor Oracle y obtener acceso adicional a un shell del sistema operativo. Para protegerse del compromiso, Oracle recomienda que todos los usuarios actualicen a la CPU 12.1.0.2 de julio de 2018.

A continuación, le mostramos cómo puede buscar servidores vulnerables de cara al público en Internet.

Este fallo en particular es significativo porque permite la explotación remota de la vulnerabilidad, aunque Oracle añade una distinción importante: La explotación remota sólo es posible si el atacante se autentica con éxito en el servidor de base de datos utilizando credenciales válidas.

La base de datos nacional de vulnerabilidades del NIST comenta la CVE:

Las versiones afectadas son 11.2.0.4, 12.1.0.2, 12.2.0.1 y 18. La vulnerabilidad, fácilmente explotable, permite a un atacante con pocos privilegios que tenga el privilegio de Crear Sesión con acceso a la red a través de Oracle Net comprometer Java VM. Aunque la vulnerabilidad está en Java VM, los ataques pueden afectar significativamente a otros productos. Los ataques exitosos de esta vulnerabilidad pueden resultar en la toma de control de Java VM. CVSS 3.0 Base Score 9.9 (Impactos en la confidencialidad, integridad y disponibilidad). Vector CVSS: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H).

Cómo encontrar servidores Oracle Database afectados por CVE-2018-3110

Utilizando Censys, realice una búsqueda de hosts que ejecuten las versiones de servidor afectadas:

1521.oracle.banner.nsn_service_versions.Authentication: 11.2.0.4* OR 1521.oracle.banner.nsn_service_versions.Authentication: 12.1.0.2* O 1521.oracle.banner.nsn_service_versions.Authentication: 12.2.0.1* O 1521.oracle.banner.nsn_service_versions.Authentication: 18*
Buscar en Censys

Añada rangos de direcciones IP que pertenezcan a su organización para filtrar los resultados. Por ejemplo

...) Y 54.0.0.0/8
Buscar en Censys

Parcheado de servidores de bases de datos Oracle

Digamos que ha encontrado algunos servidores de bases de datos afectados en los datos de Censys que ha extraído de esa búsqueda. Ahora es el momento de parchear siguiendo las instrucciones proporcionadas por Oracle para CVE-2018-3110.

Censys le ayuda a obtener visibilidad de los servidores con vulnerabilidades para que pueda ser proactivo en sus esfuerzos de seguridad de la información. Recomendamos escanear diariamente y suscribirse a listas de vulnerabilidades que comparten actualizaciones sobre versiones afectadas de productos. A continuación, puede utilizar Censys para encontrar los servidores vulnerables de su organización a los que se puede acceder desde Internet.

Envíanos un tweet si tienes algún comentario. Nos encantaría saber de ti.

Soluciones de gestión de la superficie de ataque
Más información